[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[ossec-list] Re: Server - Agent Rule Relationship
- To: ossec-list@xxxxxxxxxxxxxxxx
- Subject: [ossec-list] Re: Server - Agent Rule Relationship
- From: "Daniel Cid" <daniel.cid@xxxxxxxxx>
- Date: Tue, 24 Jul 2007 23:05:58 -0300
- Cc: "Clayton Dillard" <cdillard@xxxxxxxxxxxxxxxxx>
- Dkim-signature: a=rsa-sha1; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=a19UlczZ5ZlfqzQce3BOjsw/r9DojWOxbgM5iGaCX6cg3qCqqsoFKAFfOmctpPGxQFmXA7REAHGnSdHZfiNEpO3RkLbDdoS3R398zsFxmMrcB39ny59ZT3Obv0rEzFzSVFWY09tqNQMy5pmZ12p2QjrdHSTpZCwQiJEvdgnK0x0=
Hi Clayton,
Within the ossec model, the agents have no information about rules
whatsoever. So, if
you need to modify a rule, you need to do it on the server side.
How do you do it? If you have a rule like that (from our FAQ):
<group name="local">
<rule id="100101" level="0">
<if_sid>123, 456</if_sid>
<match>xyz</match>
<description>Events ignored</description>
</rule>
</group>
But you only want it to apply to one agent, you need to use the "hostname" tag
to limit it to the agents you want:
<group name="local">
<rule id="100101" level="0">
<if_sid>123, 456</if_sid>
<match>xyz</match>
<hostname>agent1|agent2</hostname>
<description>Events ignored</description>
</rule>
</group>
Hope it helps.
*http://www.ossec.net/wiki/index.php/Know_How:Ignore_Rules
--
Daniel B. Cid
dcid ( at ) ossec.net
On 7/24/07, Clayton Dillard <cdillard@xxxxxxxxxxxxxxxxx> wrote:
>
> I'm a bit fuzzed on the relationship between the server and agents with respect to rule processing. I have an OSSEC server with several agents connected. If I want to make a change to a rule that affects a given host, do I make the change on the server or the host(s)?
>
> Thanks,
>
> --
> Clayton Dillard <cdillard@xxxxxxxxxxxxxxxxx>
> RPS Technology, LLC
OSSEC home |
Main Index |
Thread Index
OSSEC project: www.ossec.net.
Mailling list information: http://www.ossec.net/en/mailing_lists.html.