[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[ossec-list] Re: Active Responses
- To: ossec-list@xxxxxxxxxxxxxxxx
- Subject: [ossec-list] Re: Active Responses
- From: "Daniel Cid" <daniel.cid@xxxxxxxxx>
- Date: Thu, 27 Sep 2007 21:49:49 -0300
- Authentication-results: mx.google.com; spf=pass (google.com: domain of daniel.cid@xxxxxxxxx designates 64.233.184.226 as permitted sender) smtp.mail=daniel.cid@xxxxxxxxx; dkim=pass (test mode) header.i=@xxxxxxxxx
- Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; bh=4HVXypRTVSFKfZJWIcY4R8vI5J0gIWrZUKYcTSKRlWs=; b=WdCuwB6n9liXrXv35WD4vJua2EW040Yuic1gKYYPfUf+Usi3/pfIqHbk/0rTMIMzcWrFZLdNdiE+J1wQwSKvnEYAAYFO4nhKoall/YnCqk7d5RCpUKFXpI53s3tXv2zDSSyCS2gJ1JFhtzNiwd8uERx0rz26z2kbIHbdMbG8TY4=
Hi Andy,
The best way to ignore those is to write a local rule to ignore the
event, instead of
just ignoring them for the active response. Since you know it is a
false positive, you
don't need to be seeing alerts about them.
Something like that would work (just copy to your local_rules.xml):
<rule id="100101" level="0">
<if_sid>31101</if_sid>
<url>url1_to_ignore|url2_to_ignore</url>
<description>Ignoring false positives...</description>
</rule>
Hope it helps.
--
Daniel B. Cid
dcid ( at ) ossec.net
On 9/27/07, tswmmeejsdad@xxxxxxxxx <tswmmeejsdad@xxxxxxxxx> wrote:
>
> Although it's good to enable active response for just the rules you
> want - is there a way to do the opposite that allows you to add a rule
> that won't fire off active response (like an exception list).
>
> For example I am getting a lot of web customers who have embedded
> javascript code in their HTML files that does not exsit - hence
> triggering Rule: 31151 (level 10) -> 'Mutiple web server 400 error
> codes from same source ip.'. Because I have active response turned on,
> these unknowing customer's IPs are blocked after browsing to a few
> pages within the site because the web server can't find that java
> scripts. I know it's bad coding but is there a way to exclude this
> rule from triggering active response without having to turn active
> response off.
>
> Thanks.
>
> Andy
>
>
OSSEC home |
Main Index |
Thread Index
OSSEC project: www.ossec.net.
Mailling list information: http://www.ossec.net/en/mailing_lists.html.